博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
A Knight's Journey (DFS)
阅读量:5772 次
发布时间:2019-06-18

本文共 2696 字,大约阅读时间需要 8 分钟。

题目:

Background

The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?
Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

31 12 34 3

Sample Output

Scenario #1:A1Scenario #2:impossibleScenario #3:A1B3C1A2B4C2A3B1C3A4B2C4 题意: 给你一个p*q的棋盘,跳马在上面的任意一格开始移动,只能走‘日’字,问你能不能经过棋盘上面所有的格子;(百度的题意,明明是说经过所有的格子,有道硬是翻译 成了“找到一条这样的路,骑士每一次都要去一次”),输出要按照字典顺序输出 分析: 深度优先搜索,要经过所有的格子,那就肯定经过(1,1),所以就可以从(1,1)开始搜索; AC代码:
 

#include<iostream>

#include<cstring>
#include<cstdio>
using namespace std;
int t,p,q,flag;
int a[30][30];
int step[30][30];
int f[8][2]={
{1,-2},{-1,-2},{-2,-1},{2,-1},{-2,1},{2,1},{-1,2},{1,2}};
void dfs(int x,int y,int z)
{
    step[z][1]=x;
    step[z][2]=y;
     if (z==p*q)
     {
            flag=1;
            return ;
     }

 

    for (int i=0;i<8;i++)

        {
            int xi=x+f[i][0];
            int yi=y+f[i][1];
            if (xi>=1&&xi<=p&&yi>=1&&yi<=q&&!a[xi][yi]&&!flag)
            {
                a[xi][yi]=1;
                dfs(xi,yi,z+1);
                a[xi][yi]=0;
            }
        }

 

}

int main()
{
    cin>>t;
   for (int i=1;i<=t;i++)
    {
        flag=0;
       scanf("%d%d",&p,&q);
        memset(a,0,sizeof(a));
        memset(step,0,sizeof(step));
        a[1][1]=1;
        dfs(1,1,1);
        printf("Scenario #%d:\n",i);
        if (flag==1)
         {
             for (int j=1;j<=p*q;j++)
           printf("%c%d",step[j][2]+'A'-1,step[j][1]);
             printf("\n");
         }
        else
            printf("impossible\n");
        if (i!=t)
            printf("\n");
    }
    return 0;
}

 

 

 
 

转载于:https://www.cnblogs.com/lisijie/p/7243871.html

你可能感兴趣的文章
工作流学习——Activiti流程变量五步曲
查看>>
vue开发框架搭建(详细版)
查看>>
函数计算性能福利篇(二) —— 业务冷启动优化
查看>>
分布式环境各种问题 与 CAP/BASE
查看>>
学习Python3 进程,这一篇就够了
查看>>
对Session.getAttribute(),Request.setAttribute()和ModelMap.addAttribute()用法的理解
查看>>
set uid/set gid/sticky bit、软链接、硬链接
查看>>
PublicCMS 网站漏洞 任意文件写入并可提权服务器权限
查看>>
【CentOS 7笔记】,目录权限,所有者与所有组,隐藏权限
查看>>
20181211 上课截图
查看>>
Java程序员达到高薪架构师的一套完美总结(涨薪必看)
查看>>
C# fmpeg加虹软的人脸识别demo
查看>>
Spring AOP 切面编程记录日志和接口执行时间
查看>>
线下实体店应用小程序,实现收益翻倍
查看>>
JavaScript闭包原理与用法实例
查看>>
hadoop运行java类
查看>>
Debian下自动备份MySQL数据库并上传到远程FTP服务器且删除指定日
查看>>
hadoop 网站日志分析
查看>>
最长回文串-我的算法
查看>>
Docker:启动Redis镜像
查看>>